Logo Revolt Status Machine

Email verification delays

  • Resolved
    The external provider has fixed the problem. We will continue to monitor the situation, however emails should now be sent in a timely manner.
  • Identified
    The issue appears to stem from an external service provider. We are continuously monitoring the situation.
  • Investigating
    Some users are experiencing delays in receiving verification emails, for example when creating an account.